Webmacher-FAQ

 


Excel - SUMMEWENN kurz erklärt

Bewertung: 5 / 5

Stern aktivStern aktivStern aktivStern aktivStern aktiv
 

Microsoft OfficeUm die Excel-Funktion SUMMEWENN zu erklären, bauen wir ein kurzes Beispiel: Sie haben eine Artikelliste und möchten schnell wissen, wieviel Stück eines bestimmten Artikels vorhanden sind. Das geht mit SUMMEWENN ganz einfach:

 

 

In unserer folgenden Beispieltabelle sind alle vorhandenen Artikel notiert:

 

Excel-Worksheet mit Artikeltabelle

 

Unser Ziel ist es einen schnellen Überblick zu gewinnen, wieviele Tomaten am Lager sind.

Dazu benutzen wir die SUMMEWENN-Funktion von Excel.

Schreiben Sie in eine beliebige Zelle folgende Formel (in unserem Beispiel Zelle D5):

 

=SUMMEWENN(A2:A8;"Tomaten";B2:B8)

 

Damit weisen wir Excel an

1. Den Bereich A2 bis A8 nach dem Begriff "Tomaten" zu durchsuchen und

2. bei Erfolg die dazugehörige Zelle in der gleichen Reihe aus dem Bereich B2 bis B8 zu summieren.

 

Aus diesem Grund erscheint in unserem Beispiel in Zelle D5 die Summe 81 (22 aus Zelle B2 und 59 aus Zelle B7).

 

Berechnung der Artikelanzahl mit SUMMEWENN in Excel

 

 

SUMMEWENN geht auch dynamischer

 

Um das Ganze nun etwas dynamischer zu gestalten, können wir für das Suchwort auch einen Zellbezug angeben. Schließlich interessieren Sie sich ja auch für die Anzahl der Gurken, Äpfel usw..

 

So kann das Suchwort dann je nach Bedarf angegeben werden, ohne jedesmal die komplette Formel eingeben zu müssen (alternativ kann dann in dieser Zelle auch ein Dropdownmenü hinterlegt werden. Wie das geht lesen Sie hier).

 

In unserem Beispiel soll der Artikelname in Zelle D4 stehen. Die Formel bleibt in D5 und sieht dann folgendermaßen aus:

 

=SUMMEWENN(A2:A8;D4;B2:B8)

 

(Die Anführungszeichen fallen weg, da wir nun nicht mehr nach Text suchen, sondern nur einen Zellbezug herstellen)

 

SUMMEWENN mit Zellbezug als Suchkriterium

 

Nun kann der Text in Zelle D4 beliebig abgeändert werden und der entsprechende Artikel wird summiert (z.B. Gurken. Dies sollte ebenfalls 81 ergeben.)

 

 

 

 

 

Drucken

Kommentar schreiben

Sicherheitscode
Aktualisieren