Webmacher-FAQ

 

Excel - SUMMENPRODUKT, das ZÄHLENWENN mit 2 Bedingungen

Bewertung: 5 / 5

Stern aktivStern aktivStern aktivStern aktivStern aktiv
 

Wer in Excel schonmal versucht hat, die ZÄHLENWENN-Funktion mit 2 oder mehr Bedingungen zu verwenden, kennt das Problem: Es geht nur mit Workarounds...oder mit der Funktion SUMMENPRODUKT.

 

 

Zur Veranschaulichung der Excel-Funktion, hier ein einfaches Beispiel:

Sie möchten die Werte der Spalte B summieren, wenn die Werte der Spalte A >0 und <3 sind.
Das Ergebnis sehen Sie in Zelle C12.

SUMMENPRODUKT

Folgende Formel liegt hinter C12:

=SUMMENPRODUKT(((A1:A11>0)*(A1:A11<3))*(B1:B11))

Zuerst werden die beiden Bedingungen angegeben, die der Bereich A1:A11 erfüllen muss (>0 und <3).

Danach geben Sie den Bereich an (hier B1:B11), dessen Zellen summiert werden sollen, wenn die korrespondierende Zelle im Bereich A1:A11 die entsprechenden Bedingungen erfüllt.

 

 

Drucken